2020 年 2 月
« 1 月    
 12
3456789
10111213141516
17181920212223
242526272829  

彙整

CISCO Router 簡易設定

話說某大電信的VPN服務,並不包括協助客戶端Router設定,除非是跟他們買的設備,或是花個2500請業務從外面找的配合廠商幫忙設定………大家應該猜的到是那個電信商了吧?有制度是好事,太有制度與遇到的業務不太會處理人際關係時,只好自力救濟!花了幾天時間研究簡單的指令與設定方式,最後測試是可行的,就等VPN進線實作了。

======================

一、 恢復Router出廠值:(若不知密碼,新機型後頭都有reset鍵可重置密碼,不然就上網問谷哥一下)

進入config模式

Router#configure terminal

進入0x2142模式

router(config)#config-register 0x2142

退出config模式

router(config)#exit

暖開機,選不要存檔

router#reload

System configuration has been modified. Save? [yes/no]: n

Proceed with reload? [confirm]

重開機後遇到下列問題選no

“Would you like to enter initial configuration dialog?”

改回 0x2102模式

router(config)#config-register 0x2102

寫入記憶體

router#write

更新啟動設定檔

Router#copy running-config startup-config

 

二、 初始設定精靈:

 

輸入Setup

Router#setup

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: y

At any point you may enter a question mark ‘?’ for help.

Use ctrl-c to abort configuration dialog at any prompt.

Default settings are in square brackets ‘[]’.

Basic management setup configures only enough connectivity

for management of the system, extended setup will ask you

to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: y

設定名稱

Configuring global parameters:

Enter host name [Router]: CS-R005

設定密碼

The enable secret is a password used to protect access to

privileged EXEC and configuration modes. This password, after

entered, becomes encrypted in the configuration.

Enter enable secret:

The enable password is used when you do not specify an

enable secret password, with some older software versions, and

some boot images.

Enter enable password:

The virtual terminal password is used to protect

access to the router over a network interface.

Enter virtual terminal password:

 

The virtual terminal password is used to protect

access to the router over a network interface.

Enter virtual terminal password: 2duxaiux

Configure SNMP Network Management? [no]: y

access to the router over a network interface.

Enter virtual terminal password: 2duxaiux

Configure SNMP Network Management? [no]: y

Community string [public]:

 

Current interface summary

Interface IP-Address OK? Method Status Protocol

FastEthernet0 unassigned YES unset up up

FastEthernet1 unassigned YES unset up down

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset up down

FastEthernet4 unassigned YES NVRAM administratively down down

Vlan1 unassigned YES NVRAM up up

Enter interface name used to connect to the

management network from the above interface summary: Vlan1

 

Configuring interface Vlan1:

Configure IP on this interface? [no]: y

IP address for this interface: 192.168.100.254

Subnet mask for this interface [255.0.0.0] : 255.255.255.0

[0] Go to the IOS command prompt without saving this config.

[1] Return back to the setup without saving this config.

[2] Save this configuration to nvram and exit.

Enter your selection [2]:2

 

啟用所有網路介面:

CS-R005(config)#interface fastEthernet 0

CS-R005(config-if)#no shutdown

CS-R005(config)#interface fastEthernet 1

CS-R005(config-if)#no shutdown

CS-R005(config)#interface fastEthernet 2

CS-R005(config-if)#no shutdown

CS-R005(config)#interface fastEthernet 3

CS-R005(config-if)#no shutdown

CS-R005(config)#interface fastEthernet 4

CS-R005(config-if)#no shutdown

CS-R005(config)#interface vlan 1

CS-R005(config-if)#no shutdown

 

回寫記憶體與設定檔:

CS-R005#write

CS-R005#copy running-config startup-config

Destination filename [startup-config]?

 

 

三、 設定fastErhernet 4 (WAN) IP

 

CS-R005#conf t

Enter configuration commands, one per line. End with CNTL/Z.

CS-R005(config)#interface fastEthernet 4

CS-R005(config-if)#ip address 10.10.8.254 255.255.0.0

移除IP:

CS-R005(config-if)#no ip address

 

 

四、 設定介面說明文字:

CS-R005#conf t

Enter configuration commands, one per line. End with CNTL/Z.

CS-R005(config)#interface f

CS-R005(config)#interface fastEthernet 4

CS-R005(config-if)#description WAN To Hilink VPN 100M/40M

CS-R005(config-if)#exit

CS-R005(config)#interface vlan 1

CS-R005(config-if)#description CS-Lan

 

五、 設定路由Routing Table

CS-R005#conf t

CS-R005(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.254

移除路由設定:

CS-R005(config)#no ip route 0.0.0.0 0.0.0.0 10.10.10.254

 

六、 設定dns

CS-R005#conf t

Enter configuration commands, one per line. End with CNTL/Z.

CS-R005(config)#ip name-server 10.10.10.1

移除name-server設定

CS-R005(config)#no ip name-server

 

七、 備份與還原設定檔

準備架好的 tftp

備份:

CS-R005#copy startup-config tftp

Address or name of remote host []? 192.168.100.22

Destination filename [cs-r005-confg]?

.!!

1196 bytes copied in 3.160 secs (378 bytes/sec)

還原

CS-R005#copy tftp startup-config

Address or name of remote host []? 192.168.100.22

Source filename [cs-r005-confg]?

Destination filename [startup-config]?

讀者也會看的其它文章:

    Comments are closed.